在 Xcode8运行新出的@available()宏方法

最近为了修复 MJRefersh 在 iOS 表现有问题特意做了修复代码如下

Imagem de capa

问题描述

最近为了修复 MJRefersh 在 iOS 表现有问题特意做了修复代码如下。

if (@available(iOS 11.0, *)) {
    [[UIScrollView appearance] setContentInsetAdjustmentBehavior:UIScrollViewContentInsetAdjustmentNever];
}

但是团队的其他的小伙伴还有依然使用 Xcode8进行开发的,这就导致了低版本的 Xcode8无法识别我写的代码,在编译的时候就包错误了。

解决方法

#if __IPHONE_OS_VERSION_MAX_ALLOWED > __IPHONE_10_3
if (@available(iOS 11.0, *)) {
    [[UIScrollView appearance] setContentInsetAdjustmentBehavior:UIScrollViewContentInsetAdjustmentNever];
}
#endif

为什么判断是

#if __IPHONE_OS_VERSION_MAX_ALLOWED > __IPHONE_10_3

因为 Xcode8支持最后的系统是__IPHONE_10_3如果等于就会走编译,不能用__IPHONE_11_0是因为低版本的 Xcode 依然识别不了。

其实最安全的是后面代替为整数即可。

6FD0AEA4-0C7A-4A6C-B3A7-39FB7718C9B5